Features

Why is a new or edited Job Custom Field in Xero Practice Manager not showing straight away in FYI?

Issue

I have set up a new Job Custom Field in Xero Practice Manager, but it is not showing in FYI.

I have tried the manual Sync and the Sync from PM in the Job - Custom Fields tab, but it is not available to select as a filter in FYI.

Cause

The manual Sync and the Sync from PM in the Job - Custom Fields tab will sync updates to Custom Field values only.

Changes to the Custom Field definitions, including newly created Custom Fields, are only synchronised overnight.

Solution

Custom Field Definitions

Changes to Custom Field Definitions in XPM are synchronised with FYI overnight automatically unless Sync Custom Fields from XPM is set to "Off" in the Xero Practice Manager automation app settings, in which case Custom Fields aren't synchronised at all.

You will need to wait until the automatic sync has been completed.

Custom Field Values

If you have updated the value within a Custom Field, for example, to add a new option to a drop-down, the frequency of the Custom Field sync will depend on your settings:

Note: Jobs will be marked with a Pending Sync tag while waiting for the updates to be synced with Xero Practice Manager. This tag is located beside the Job Name on the Job Summary tab. When the Job is marked as Pending Sync, Custom Field changes made in XPM will not be synchronised.

Note: An FYI Admin can add a Job Custom Field in FYI, which will be available to use straight away. Refer to Managing Custom Fields.

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