Issue
I have set up a Job Custom Field in Xero Practice Manager, but it is not showing in FYI. I have tried to the manual Sync and the Sync from PM in the Job - Custom Fields tab, but it is not available to select as a filter in FYI.
Cause
For practices on the Elite plan where FYI is the Primary Source for Client Maintenance, Custom Fields will only be synchronised one-way, from FYI to Xero Practice Manager. Refer to Synchronising with Xero Practice Manager where FYI is enabled for Primary Source of Client Data.
For all other plans, or where FYI is not enabled as the Primary Source for Client Maintenance, Custom Fields will be synchronised from Xero Practice Manager. However, new or edited Custom Field definitions (for Clients and Jobs) are not available on the day they are created or edited.
The Job Custom Field definitions are only synced from Xero Practice Manager to FYI during the automatic overnight synchronisation.
The Sync from PM button in the Job - Custom Fields tab will sync any changes to the values selected for a Custom Field, but will not sync changes to the Custom Fields themselves.
Solution
If you want to use a Custom Field in a View or in an Automation, add or edit this the day before so it is available for selection in Views and Automations.
Note: An FYI Admin can add a Job Custom Field in FYI, which will be available to use straight away. Refer to Managing Custom Fields.