Features

Error "Invalid Job Identifier" when assigning jobs

Issue

When updating a job to assign a Job to a Partner or Manager, one of the following messages is displayed:

  • FYI-2237: Error exporting job state - Invalid job identifier
  • FYI-2246: Unable to assign the job to users - Invalid job identifier

Cause

For practices integrated with Xero Practice Manager, the Job has been deleted in Xero Practice Manager and therefore cannot sync the changes.

Solution

You will need to create a new job and transfer information to the new job, for example, Comments and Tasks.

  1. Create a new job in Xero Practice Manager.

  2. Run a manual sync of Jobs in FYI. 

  3. Locate the new Job in FYI.

  4. Manually copy all the comments to the new Job from the deleted Job that is showing in FYI. Review the Job - Comments tab for a list of comments associated with the job.

  5. Update the filing for any documents to be against the new Job.

  6. Create any Tasks associated with the Job again.

  7. Update the Job State for the deleted Job to "Completed" in FYI so it will not show in active Jobs. 
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