Issue
For practices integrated with Xero Practice Manager, when the TFN for Australian sites (or the IRD number for New Zealand sites) syncs through to FYI, this only shows the last three numbers.
Cause
The TFN/IRD number that flows through to FYI from Xero Practice Manager only shows the last three numbers due to security reasons imposed by Xero Practice Manager.
Solution
Practices where FYI is not enabled as the Primary Source for Client Data:
If you require this information in full, a solution would be to create a Client Custom Field in Xero Practice Manager for the TFN/IRD number. FYI will then be able to read the full number.
Important note: Xero Practice Manage hides the value for specific security reasons.
FYI does not recommend that you add the TFN/IRD number as a Custom Field, However, if you chose to do this, FYI will be able to use this information.
Custom Fields display on the Client - Custom Fields tab (refer to Client Custom Fields).
Custom Fields can also be included as Merge Fields (refer to Merge Fields for Custom Fields in Including Merge Fields in Word Templates and Stationery and Custom Fields (XPM group) in Including Merge Fields in Email Templates and Signatures). Custom Fields can also be used in Automations.
Practices where FYI is enabled as the Primary Source for Client Data:
Practices on the Elite plan or where FYI is Enabled as the Primary Source for Client Data, the Tax Number or IRD will be displayed partially masked when first synchronised from Xero Practice Manager. Once edited in FYI the full value will display. FYI Admins or users with Edit Clients permissions will have permission to Edit the Client Details.