Features

Excel Report not generated and a Notification was not received

Issue

After creating a Report in FYI, the user did not receive a notification to confirm the report was generated successfully.

In addition, an error is displayed in Practice Activity to show the report was not generated. The Practice Activity drawer for the error links to the Automation History, where the following error is displayed:

  • FYI-2668: Unable to generate report, update the selected Report Views to reduce the size of the report and retry.

Cause

The view selected when creating the report contains an excessive amount of data, and exceeds FYI's processing capacity.

This can typically occur when the View selected on the report includes extensive data, such as selecting all available columns in the view or working with large datasets.

Solution

To ensure a report is generated successfully, you will need to reduce the amount of data in the report by using one or more of the following options:

If you still experience issues creating the report after applying all the suggested options above to reduce the report data, please contact our support team for assistance.

Option 1 - Use Filters to Segment Data

Consider creating smaller data segments, by filtering your view. The ability to sort and filter views is similar across different workspaces, refer to Sorting and Filtering Documents Lists.

If required, create multiple smaller reports focusing on these specific segmented views.

Option 2 - Deselect "Include All Columns" when creating the Report

Reducing the number of columns included in the report, by unticking 'Include All Columns' in the Create Report Drawer.

Option 3 - Check the View used is not an "All" List View

Check that the View selected when creating the report is not using an 'All' List View, as these contain large amounts of data.

For optimised reporting, it is recommended that a view is created with segmented data specific to the report requirements.

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