Issue
When synchronising Job updates to Xero Practice Manager, the following error is displayed in Practice Activity:
- Error FYI-2240: Error updating Job Details - Not Found
Cause
The Job Number in Xero Practice Manager contains symbols or invalid characters.
Due to a limitation with the Xero Practice Manager, the API allows Jobs to be created containing invalid characters but then prevents updates from being applied.
Solution
A new job will need to be created and synchronised to FYI, with information transferred to the new job, for example, Documents and Tasks.
- Create a new job in Xero Practice Manager.
- Run a manual sync of Jobs in FYI.
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Locate the new Job in FYI.
- Manually copy all the comments to the new Job from the deleted Job that is showing in FYI. Review the Job - Comments tab for a list of comments associated with the job.
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Update the filing for any documents to be against the new Job.
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Create any Tasks associated with the Job again.
- Update the Job State for the deleted Job to "Cancelled" in FYI so it will not show in active Jobs.