Issue
When trying to remove a user from the Client - Sharing Settings, the following error is displayed:
- Unable to remove a user from Sharing Settings
Cause
The user has been manually deleted from Entra by a Microsoft 365 Administrator.
In these cases, Collaborate will not be able to remove the guest user from the client's Sharing Settings, and the New Collaborate Status Check will be unable to recreate the guest user account.
Solution
The user will need to be manually removed from the SharePoint Site Collection.
- Log in to the New Collaborate SharePoint site as the practice's OneDrive Admin User.
- Click the Settings cog icon in the top right-hand corner.
- Click Site Permissions - Advanced Permissions Settings.
- Click on the SharePoint site Visitors group.
- To load the SharePoint Site Collection, in the browser URL, change the MembershipGroupId= value to 0.
- Locate the guest account account and tick the box to select it.
- Click the Actions drop-down and select Delete Users from Site Collection.
- In FYI, refresh the Client - Collaborate tab.
- Click Sharing Settings. The client's email address should no longer be displayed.