Error "Progress or Final Invoice must have at least one job selected."
Issue
When creating an invoice with the type "Progress" or "Final" the following error appears:
"Progress or Final Invoice must have at least one job selected".
Cause
This error can occur in two scenarios:
When creating an invoice either:
No Billing Job with Workflow Jobs has been selected.
No Standard Job has been selected.
When a Billing Job with Workflow Jobs or Standard Job has been selected, there is no unbilled WIP recorded for the chosen jobs.
Solution
When creating a Progress or Final Invoice, ensure that in the Job section of the Create Invoice Job Drawer a Standard or Billing Job with open Workflow Jobs is selected. The jobs selected must have unbilled time recorded to successfully create the invoice. Refer to Create an Invoice.