Issue
When using Generic Practice Sync to upload File Notes, the CSV file shows as processed in Practice OneDrive, but no File Notes have been uploaded to FYI.
Cause
When creating a CSV file to import File Notes to FYI, the date formatting may automatically revert to the default date format configured on your system. It is important that the date formatting matches one of the following:
- YYYY-MM-DD
- YYYY-MM-DD HH:mm
- YYYY-MM-DD HH:mm:ss
Solution
Ensure that you update the date formats in the columns CreatedOn and ModifiedOn to match the correct formatting. Refer to CSV Files for the integration with Generic Practice Management Software
To check if your date format is correct:
- Select the CSV file
-
Right-click and select 'Open with Notepad'
Note, this step should be done only once -
Check the date format in Notepad to ensure it matches one of the following formats:
YYYY-MM-DD
YYYY-MM-DD HH:mm
YYYY-MM-DD HH:mm:ss
- If the format is incorrect update the date in Excel using the "Format Cells" function and perform steps 1-3 above to ensure the formatting was not reverted.
When the formatting is correct, check all other formatting, including column headings. Refer to CSV Files for the integration with Generic Practice Management Software.
Once satisfied the file is correct, proceed with uploading the file to the Practice Sync folder. Refer to Integration with Generic Practice Management Software