Features

Error FYI-2214 "Internal users cannot be added to Sharing Settings."

Issue

When adding a user to the New Collaborate Sharing Settings window, the following error is displayed:

  • Internal users cannot be added to Sharing Settings. Please add external guest emails only. To manage internal user access, refer to the selected Microsoft Group within the Collaborate App.

Cause

The error can be caused by one of the following:

The email address, or one of the emails if entering multiple addresses, has been identified as an internal user. This could mean:

  • The user access is controlled through the selected Microsoft Group in the New Collaborate App settings in FYI, and not through the Sharing Settings on the client, or

  • The client's email domain matches the OneDrive administrator's email alias. For example, if the client's email was 'frankmarshll@yahoo.com', and the OneDrive Admin's email address was 'joeblogg@yahoo.com'. OneDrive determines whether a user is internal or external based on the admin's email domains.

Solution

Confirming the Microsoft Group Selected

To find which Microsoft Group has been selected, navigate to Automation - Apps and select the Collaborate - Client App. The Microsoft Group will be displayed.

To confirm the user has been added to this Microsoft Group, refer to your IT Administrator.

2654 Collaborate Configuration.gif

Removing the OneDrive Admin Email Alias

If the OneDrive Admin user's Email Alias matches that of the client:

  1. An FYI Admin should remove the email alias from the User profile.

This will prevent OneDrive from misidentifying the client's email address as an internal user. You can then add your client's email address in the Sharing Settings.

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