Plan: Not Available: Intermediate Available: Pro or Elite
Users: Not Available: All users, User Group Permissions Available: FYI Admins
Practice Management Source: Available: All sources
Issue
When adding a user to the New Collaborate Sharing Settings window, the following error is displayed:
- Internal users cannot be added to Sharing Settings. Please add external guest emails only. To manage internal user access, refer to the selected Microsoft Group within the Collaborate App.
Please note that this issue occurs when adding clients from the Client - Collaborate Sharing Settings tab.
To add internal users to a Client Secured Collaborate site refer to Client Security.
Cause
The email address, or one of the emails if entering multiple addresses, has been identified as an internal user. This could mean:
- The client's email domain matches the OneDrive Admin user's email alias. For example, if the OneDrive Admin email address is "admin@mypractice.com", any user with the email domain "mypractice.com" added to New Collaborate would be considered an internal user.
- The user already exists in Microsoft Entra with a Type of Member.
Internal user access is controlled through the selected Microsoft Group in the New Collaborate App settings in FYI, and not through the Sharing Settings on the client.
Solution
Confirming the Microsoft Group Selected
To find which Microsoft Group has been selected, navigate to Automation - Apps and select the Collaborate - Client App. The Microsoft Group will be displayed.
To confirm the user has been added to this Microsoft Group, refer to your IT Administrator.
Removing the OneDrive Admin Email Alias
If the OneDrive Admin user's Email Alias matches that of the client, an FYI Admin should remove the email alias from the User profile.
This will prevent OneDrive from misidentifying the client's email address as an internal user. You can then add your client's email address in the Sharing Settings.
Confirm the user's Type on Microsoft Entra
If the user has been added to Microsoft Entra with a Type of "Member", the user will be identified as an internal user. For further information, or to remove the user as a Member, refer to your IT Administrator.