Features

Occasional Delays in Syncing with Xero Practice Manager

Issue

We are currently aware of occasional delays in the sync from Xero Practice Manager to FYI.

We are also currently experiencing delays due to Xero's new oAuth. Refer to Occasional Delays in Syncing with Xero Practice Manager due to Xero's new oAuth and Xero Practice Manager Rate Limiting

Cause

All automatic sync requests are placed into a queue to process within FYI. Once processed, the FYI platform requests the data from Xero Practice Manager and updates your practice data accordingly. When there are large numbers of sync requests, a queue backlog is created, affecting our sync time frequencies. 

Solution

Minimise the Queue Backlog

To minimise a queue backlog for sync requests, please consider the following: 

While we have limited control over the syncing process with Xero Practice Manager, we are currently developing enhancements to increase visibility and frequency on syncs, including: 

  • Prioritising different areas of the Xero Practice Manager sync to ensure that time-sensitive updates are actioned over more stagnant changes. 

  • Increasing the availability to update details in FYI so that changes can be reflected immediately in Xero Practice Manager. 

Reconnect to Xero

If data appears to have stopped synchronising altogether, you can disconnect and reconnect to Xero Practice Manager.

Refer to Resetting your connection between FYI and Xero Practice Manager.

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