Issue
On occasion, there may be delays in the sync between Xero Practice Manager and FYI. Refer to Occasional Delays in Syncing with Xero Practice Manager due to Xero's new oAuth and Xero Practice Manager Rate Limiting
Cause
Sync requests are placed into a queue to process within FYI. Once processed, the FYI platform requests the data from Xero Practice Manager and updates your practice data accordingly. When there are large numbers of sync requests, a queue backlog is created, affecting our sync time frequencies.
Solution
Minimise the Queue Backlog
To minimise a queue backlog for sync requests, please consider the following:
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Do not request the Sync multiple times. Each time the Sync is requested it sends another request into the queue which decreases system response times. As each of these synchronisations occur, the number of available requests will be reduced. Once the Rate Limit has been reached, no further synchronisations will be performed that day. Refer to Xero Practice Manager Rate Limiting
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Update all Job States in FYI directly. Please note that if you are renaming or deleting a Job State in Xero Practice Manager, these are not automatically updated in FYI. For details on how to archive, rename or delete a Job State in FYI, refer to Job States.
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If relevant, sync only what is needed at that time (for example, Clients, Jobs, Users or Tax Returns. Refer to Running a Manual Sync with Xero Practice Manager and Additional Notes on Syncing.
- For practices on the Elite plan with FYI selected as the Practice Management solution, FYI will be automatically enabled as the Primary Source for Client Data. Refer to Synchronising with Xero Practice Manager where FYI is enabled for Primary Source of Client Data.
While we have limited control over the syncing process with Xero Practice Manager, we are currently developing enhancements to increase visibility and frequency on syncs, including:
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Prioritising different areas of the Xero Practice Manager sync to ensure that time-sensitive updates are actioned over more stagnant changes.
- Increasing the availability to update details in FYI so that changes can be reflected immediately in Xero Practice Manager.
Reconnect to Xero
If data appears to have stopped synchronising altogether, you can disconnect and reconnect to Xero Practice Manager.
Refer to Resetting your connection between FYI and Xero Practice Manager.