Features

Why is an Automation Process not completing?

Issue

An Automation Process is showing in Process History as not complete, or it does not create the email or document until you complete a Task created in the process.

Cause

The reason for this could be that a step in the automation has the task set as a "blocking" task and has Blocking set to "On". These tasks are displayed with an icon of a tram with an alert symbol.

1760 Blocking Task in Process History Checklist.gif

Until the status of the Task is set to "Complete", the next step in the process or the overall completion of the automation, will not happen. This could also be the case if the Process only holds one step.

Solution

Change the setting in the Task being created in the Process so it is no longer a blocking task by setting Blocking to "Off". Refer to Task in Steps in Process Step Details - Creating Documents and Tasks.

The Automation Process will then show there are no steps outstanding regardless of whether or not the task is marked as complete.

Note: If the Status of the blocking Task is set to "Rejected," the process will not proceed to the next step.  The process itself will stay in a "Progress" status.

Was this article helpful?
0 out of 1 found this helpful