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Issue
When I open an Excel spreadsheet or use it as a template:
- A message displays that the spreadsheet file or macro-enabled spreadsheet is corrupted.
- Excel gives a prompt to repair the file.
- The spreadsheet does not open.
Causes
See also Reverting to a Previous Version.
Spreadsheets not uploaded correctly via OneDrive
This can be caused where, in the past, spreadsheets have not been uploaded correctly via OneDrive. Having a file that has not been uploaded correctly can cause issues with other documents.
This is a Microsoft error. Refer to the Microsoft article Files Needing Attention FAQ.
With OneDrive, the upload can be an issue with macro-enabled spreadsheets, especially where the spreadsheets are large or include references to other spreadsheets or where they use pivot tables.
Solution
The following is the recommended best practice to avoid this issue and needs to be performed on each computer that is having the issue:
- Ensure your computer is correctly configured to work offline with FYI, including OneDrive. Refer to Configuring your OneDrive for use with FYI.
- In the relevant Office application (Word, Excel or PowerPoint) check if there are any Files Needing Attention. Files that have failed to upload need to be removed.
1. Open the relevant Office application (Word, Excel or PowerPoint).
2. In File - Open, check for any files in that application that are showing as Files Needing Attention. Refer to the Microsoft article Files Needing Attention FAQ.
3. From Files Needing Attention, you can open the file and re-save, or, you can discard the changes completely.
4. Try editing a document again.
Note: Office Upload Centre has now been deprecated and replaced with the Files Needing Attention function in the relevant Office application.
Important Note: For all of the following possible solutions, check with your IT consultants or department that it is OK to do so before changing these settings.
- Ensure trusted locations and documents on your network are enabled in Excel.
a) Open Excel and select File - Options - Trust Center
b) Click Trust Center Settings.
c) Go to Trusted Locations.
d) Checkmark Allow Trusted Locations on my network.
e) Uncheckmark Disable all Trusted Locations.
f) Click OK.
- Allow documents on a network to be trusted
In Excel File - Options - Trust Center - Trust Center Settings.
a) Click Trusted Documents.
b) Checkmark Allow documents on a network to be trusted.
c) Click OK.
- Enable Macros
This setting is your choice, if you are using macros (note that macros do not work in Excel online)
In Excel File - Options - Trust Center - Trust Center Settings.
a) Click Macro Settings.
b) Select Enable all macros.
c) Click OK.
- Turning off protected views
Check with your IT consultants or department that it is OK before changing these settings. Refer also to this Microsoft article regarding the protected view What is Protected View?
In Excel File - Options - Trust Center - Trust Center Settings.
a) Click Protected View.
b) Remove all checkmarks to disable all Protected View
c) Click OK.
OneDrive is corrupting macro-enabled spreadsheets
Cause
Where the spreadsheet is macro-enabled, it is being corrupted by OneDrive, and not FYI.
Solution
It's recommended to try the following methods to resolve the issue:
- Transfer the contents across to a new file.
Note: For FYI, if the file is used in FYI as a template, also transfer it to a new template.
- Turn off auto-save, so the user can control the saving.
Note: For FYI, turning off auto-save can cause implications, as you may lose data if you have an issue with your computer. This is not something that FYI would generally recommend. We recommend you only turn AutoSave "Off" on macro-enabled spreadsheets.
When using Excel desktop, you use the AutoSave toggle in the top left-hand corner of the spreadsheet to set this to "Off" or "On".
Reverting to a Previous Version
If there are issues with a spreadsheet getting corrupted, revert to a previous version of the file in FYI.
- Separate versions are automatically maintained within FYI.
- Versions are created whenever a user stops editing a file (with the I am finished editing button)
- In the document drawer, users can access the earlier versions and restore an older version and set it as the current version.
For details on using versions in FYI, refer to Document Version History - Creating a New or Recovering a Document Version.
Contact Support
Please also contact the FYI Support Team to advise of a corruption issue.