Features

Collaborate using OneDrive - Secure Link is Inactive

Support has now ended for Legacy Collaborate.

To upgrade to New Collaborate, refer to Upgrading to New Collaborate.

Issue
When sending documents to your clients via Collaborate, the client receives an email which includes a secure link to each of the documents stored in OneDrive. The client clicks on the link to access the document. Refer to Sharing Documents via Collaborate.

This article explains what to do if there is an issue where the OneDrive secure link to attachments sent to the client in the email is inactive or cannot be clicked.

Cause
There are the following possible reasons why the secure links created by FYI are inactive:

  • Collaborate within FYI Automation hasn't been configured
  • In OneDrive Administration, External Sharing is turned "OFF"
  • In OneDrive Administration, link expiration days have been set
  • The recipient is already a named user or guest in Office 365

Solution

1. Collaborate within FYI Automation hasn't been configured

The prerequisite for sharing documents securely with clients from within FYI is to configure Collaborate. 

2. External Sharing is set off within the OneDrive Admin Account for your practice. Refer also to OneDrive Admin Account.

This needs to be done by a Microsoft 365 administrator.

  • Go to Microsoft 365 admin centre

  • Open OneDrive and click Sharing

  • Review the settings at External sharing

Refer to this external reference Manage sharing settings in Microsoft 365

3. Link expiration days are set on the OneDrive Admin account.

This needs to be done by a Microsoft 365 Administrator.

  • Go to Microsoft 365 admin centre

  • Open OneDrive using this link

  • Expand Advanced settings for shareable links and update the link expiration days

  • Click Save

Refer to this external reference Manage sharing settings in Microsoft 365

4. The email address must not be a licensed user or guest in Microsoft 365

Creating a secure link to share a document via FYI Collaborate will not work for existing users within a practice's Microsoft 365 account, including:

  • licensed users
  • guest users

What this means is you cannot use or even test Collaborate with a licensed or guest user of Microsoft 365 within your practice. Instead, use a test email address from Gmail or other external email providers.

Also, if you have already shared documents with an email address using the native OneDrive/SharePoint features, any guest user account will have to be removed before using FYI Collaborate with that address.

Removing these guest accounts is done by:

  • Opening guest user list within Microsoft 365 from this link.
  • Select the guest(s) that you want to delete
  • Then select Delete from the top menu
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