Features

Why are Merge Fields in an Email Template or Signature not working correctly?

Issue

I have set up an email Template or Signature with Merge Fields to bring in client or user information, but it is not bringing in the information, or it is bringing in the wrong information.

You may also encounter an error importing the document:

  • Error creating document. Unable to process template or signature. Merge Field formatting invalid".

Cause

  • The Merge Field may not have been added correctly, or an incorrect field has been added to the Template or Signature.

  • Merge Fields can be edited in the same way as text in the Template Editor so you may have accidentally changed something in the Merge Field.

  • If the email has been created as "Draft in FYI", some of the user information will show as the Merge Field. This is because emails that are "Draft in FYI" only add the information when the email is sent from FYI, or transferred to Outlook. The reason for this is that certain Merge Fields are only applied when the final sender of the email has been determined; these fields do not display when editing the draft email in FYI. 

  • If Tax-Related Merge Fields are not being pulled through to FYI and you are not seeing the data for a Notice of Assessment, the Notice of Assessment may have been archived.

Solution

Check the following:

Merge Field formatting

  • Check that the Merge Field has two curly brackets for the opening and closing brackets.

  • Make sure there is a space after the opening curly brackets and before the closing curly brackets.

  • Make sure the brackets are on the same line (so there are no line breaks in the Merge Fields).

  • If you have applied any formatting to the text, this may have been added incorrectly. Try adding the Merge Field without any formatting and check the result, then apply any formatting once you know the Merge Field is working correctly.
    You can also check the HTML code of an email Template or Signature. Refer to Creating an Email Signature using HTML and Merge Fields.

  • Confirm the Merge Field has been added directly to the template, not as a link in a URL. Check each of the links by clicking on the link, and clicking the pencil icon. If a Merge Field appears in the URL box, it must be removed, and the Merge Field added directly to the template. Refer to Creating an Email Signature using HTML and Merge Fields.

    3141_Email_Template_Merge_Field_URL.gif

Re-add the Merge Field

  • Add the Merge Field again from the Template Editor in case the name of the Merge Field has been accidentally changed.

  • Check that you are including the correct field. The help articles for Word Templates include a link to the document FYI Merge Fields.docx which you can download. This gives additional information about the Merge Fields. Refer to Including Merge Fields in Word Templates and Stationery to download the document.

  • If you are not seeing the correct value for the Merge Field ‘Contact Name', and your practice is integrated with Xero Practice Manager or using FYI as the practice management source, note that this uses the name of the primary contact. Ensure a Primary Contact has been selected for the client in Xero Practice Manager.

Merge Field Contents

  • If you are seeing the Merge Fields for the user information, send the email or transfer it to "Draft in Outlook" to check the information that flows through. Note that once the email is sent to Outlook, any further changes must be made from Outlook (including sending the email). Emails that are sent to Outlook will be immediately marked as "Sent" in FYI, and the Workflow Status will be set to "Completed".

  • If Tax-Related Merge Fields are not being pulled through to FYI and you are not seeing the data for a Notice of Assessment, the Notice of Assessment may have been archived. Change the Notice of Assessment to unarchived so the data can be retrieved by FYI. Refer to Including Advanced Tax-Related Merge Fields.
Was this article helpful?
0 out of 1 found this helpful