Issue
After changing the Job State on a job in FYI, the update has not synchronised to Xero Practice Manager and the Job State has been reverted to the previous selection. In addition, the following error is displayed in Practice Activity:
- Error updating Job State - Bad Request
Cause
The Job State was created using a long dash (—) or a short dash (–) instead of a hyphen (-), likely from copying and pasting text into the field from an Office app e.g. Word.
Long and short dashes are incompatible with the Xero API, and cannot be used in a Job Name.
Solution
To resolve the issue:
-
Update the Job State Name in Xero Practice Manager to replace the long or short dash with a hyphen.
- Run a Job Synchronisation - refer to Running a Manual Sync with Xero Practice Manager and Additional Notes on Syncing
Note: The Job State must be assigned to at least one active job before it will be synchronised to FYI.
- The updated Job State will be added as a new Job State in FYI. You will need to archive the former Job State with the long dash in the name. Refer to Managing Job States.