Features

Error when exporting invoices to Xero Ledger due to Matching Contacts

Issue

After synchronising an invoice with Xero Ledger, an error similar to one of the following is displayed in Practice Activity:

  • Could not export invoice.
  • Error exporting invoice - The contact name matches another contact that already exists in Xero
  • Error exporting invoice - Cannot create or update contact as Contact Name is already assigned to another contact.
  • FYI-2172 The contact has been archived in Xero, and will need to be restored.

Cause

When synchronising invoices to Xero Ledger, a check is made for whether there is an existing contact. Refer to Invoicing Overview.

Where possible, the invoice will still be synchronised. For example, if the Contact Name was unable to be updated, the invoice will still be synchronised to the contact with the existing name, and an error regarding the Contact Name will be displayed in Practice Activity.

If the invoice cannot be synchronised, the issue will be due to one of the following reasons:

  • Trying to assign the invoice to an archived contact.

  • The FYI Client ID has been used as the Contact Code for a different contact in Xero.
    Note: The FYI Client ID is displayed on the Client - Summary tab.

Solution

You will need to update the Contact in Xero.

Step 1 - Locate the Matching Contact

To investigate which contact FYI is trying to synchronise the invoice to, check Xero for the following:

  • Review the Contacts - All Contacts - Archived list to check if the contact has been archived.
     
  • As Xero doesn't allow for searching using the Contact Code, search for matching contacts using the email address. Check each contact's Contact Details tab to review the Contact code, to find if the FYI Client ID has been used for a different contact.
    Note: If FYI has been configured to use a Client Custom Field for the invoice email address, you will need to search Xero using the email address in the custom field. Refer to Managing Invoices Settings.

Step 2 - Update the Contact

Archived Contact

If the contact has been archived, you will need to restore the contact.

  1. In Xero, open the Contacts menu, and select All contacts.

  2. Select the Archived tab.

  3. Click the contact to open their details, then click Restore.

  4. Click Restore to confirm.

For more information on restoring contacts, refer to the Xero article Archive or restore contacts.

Active Contact

If the contact is active, but the Contact Name has been assigned to a contact with a different Client Code, you will need to rename the client. This allows FYI to sync the invoice and create a new contact. Once the invoice has been created, the contacts can then be merged.

  1. In Xero, open the Contacts menu and search for the contact to be updated.

  2. Next to the contact name, click the three dots menu icon and click Edit.

  3. Update the Contact Name, for example, "Frank Marshall (old)".

  4. Click Save & close.

Step 3 - Resubmit the Invoice

If the invoice was unable to be created in Xero, you should now try synchronising invoices again to see if the error remains. One or more invoices can be resubmitted at a time.

  1. From FYI, go to Practice - Invoices.

  2. Filter the Status column to "Sync Exception" to find impacted invoices. 

  3. Tick one or more invoices, and click Resubmit.
    3367_Practice_Invoice_Resubmit.gif

Step 4 - Merge Duplicate Contacts in Xero (Optional)

Merge the duplicate contacts in Xero, ensuring the contact used by FYI is retained. 

  1. In Xero, open the Contacts menu and select All contacts.

  2. Select the checkbox for each contact you want to merge.
    Note: You only need to select the duplicate accounts for this step, and not the restored contact.

  3. Click Merge.

  4. Start typing the name of the contact you want to merge into, and then select the contact.
    Note: This is the contact restored in the previous step. 

  5. Click Merge, then click Confirm merge.

  6. Review the Contact details of the merged contact and update if necessary.

For more information on merging contacts, refer to the Xero article Merge contacts.

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