Features

Error when exporting invoices to Xero Ledger due to Archived Contacts

Issue

When creating an invoice in FYI the invoice is not synchronised to Xero Ledger, and one of the following errors is displayed in Practice Activity:

  • Error exporting invoices - The contact with the specified contact details has been archived. The contact must be un-archived before creating new invoices or credit notes. 

Cause

When synchronising invoices to Xero Ledger, a check is made for whether there is an existing contact based on the Contact's Code and Name. Refer to Invoicing Overview.

Invoices cannot be created in Xero Ledger for contacts that have been archived. Where the archived contact is the account that FYI synchronises invoices to, it will need to be restored to be the active account. 

Solution

Step 1 - Restore the Contact

To restore the contact:

  1. In Xero, open the Contacts menu, and select All contacts.

  2. Select the Archived tab.

  3. Click the contact to open their details, then click Restore.

  4. Click Restore to confirm.

For more information on restoring contacts refer to the Xero article Archive or restore contacts.

Step 2 - Resynchronise Invoices

You should now try synchronising the invoices again to see if the error remains. 

  1. From FYI, go to Practice - Invoices.

  2. Filter the Status column to "Sync Exception" to find impacted invoices. 

  3. Tick one or more invoices, and click Resubmit.
    3367_Practice_Invoice_Resubmit.gif

Step 3 - Merge Duplicate Contacts in Xero (Optional)

Merge the duplicate contacts in Xero, ensuring the restored contact used by FYI is retained. 

  1. In Xero, open the Contacts menu and select All contacts.

  2. Select the checkbox for each contact you want to merge.
    Note: You only need to select the duplicate accounts for this step, and not the restored contact.

  3. Click Merge.

  4. Start typing the name of the contact you want to merge into, and then select the contact.
    Note: This is the contact restored in the previous step. 

  5. Click Merge, then click Confirm merge.

For more information on merging contacts, refer to the Xero article Merge contacts.

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