Error FYI-2151 "Guest users were successfully removed from SharePoint, but we were unable to remove them from Microsoft 365" when removing a user from Sharing Settings."

Plan: Not Available: Intermediate Available: Pro or Elite

Users: Not Available: All users Available: FYI Admins or User Group permissions

Practice Management Source: Available: All sources

Issue

When trying to delete a user from the New Collaborate Sharing Settings, the following error is displayed:

  • Guest users were successfully removed from SharePoint, but we were unable to remove them from Microsoft 365.

Cause

The OneDrive Admin account does not have the "User Administrator" role applied. As a result, the user was able to successfully be removed from the New Collaborate SharePoint site, but not from Microsoft 365.

Solution

A user with access to the Microsoft Entra Admin Centre will need to manually remove the user. Refer to the Microsoft article Add or delete users.

Consider whether it is appropriate for your practice to update the OneDrive User account, and prevent this issue from reoccurring, refer to Step 3 in Setting up Microsoft 365 for New Collaborate.

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