Error "Could not add user to site. Refresh page and try again" when adding a user to New Collaborate Sharing Settings

Issue

When trying to add a client to the New Collaborate Sharing Settings the following error is displayed:

  • Could not add user to site. Refresh page and try again.

Cause

This issue can be caused by the following:

  • There is a restriction in place of the ability for internal users to invite guests to SharePoint (using Assigned Roles) and the OneDrive Admin User has not been assigned the "Guest Inviter" role.

  • The Collaborate SharePoint site may have the External Sharing configured to "Only people in your organisation", preventing guests from being added to the SharePoint site.

Solution

Add the Guest Inviter Role

This step is only required if the site configuration has been set to "Only Users assigned to specific admin roles can invite guest users", you will need to add the "Guest Inviter" role to the Practice OneDrive Admin user.

Refer to How to restrict the ability for internal users to invite guests to SharePoint (Assigned Roles method).

Review the SharePoint Sharing Settings

Ensure your configuration settings match the required Collaborate Settings. Refer to Setting up and Enabling Azure AD B2B for New Collaborate.

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