Plan: Not Available: Intermediate Available: Pro or Elite
Users: Not Available: All users Available: FYI Admins or User Group permissions
Practice Management Source: Available: All sources
Issue
When running the New Client Collaborate Status Check or Client Secured Collaborate General Status Check for a user, the following error is displayed:
- We were unable to restore access for the guest user to the Collaborate Site. Please refer to the article for troubleshooting steps.
Cause
New Collaborate was unable to re-add the guest user account to the SharePoint site's Visitor Group.
This is typically caused by:
- The practice's OneDrive Admin user has been changed but has not been updated as an owner of the SharePoint site
- The Sharing Settings at an organisation or site level have been changed to restrict the ability to invite external users or domains
- The Sharing Settings in Microsoft Entra/SharePoint are set to only allow users with specific roles to invite guest users, and the practice's OneDrive Admin user does not have the Guest User or User Administrator roles applied.
Solution
To resolve the issue, you will need to:
- Run the New Client Collaborate Status Check or Client Secured Collaborate General Status Check and click "Fix" for any identified errors. Refer to Checking your New Collaborate Status.
- The New Client Collaborate Status Check can be accessed via Automations - Apps - "Collaborate - Client".
- The Client Secured Collaborate General Status Check can be accessed from the Client - Collaborate tab.
- Verify Microsoft 365 has been configured correctly for New Collaborate. Refer to Setting up Microsoft 365 for New Collaborate
- From the Client - Collaborate tab, click the Sharing Settings button. New Collaborate will automatically run the Client Status Check to validate the permissions for the users displayed. Refer to Checking your New Collaborate Status