Features

Error FYI-2131 "We were unable to create the guest user in Microsoft 365" when adding a user to New Collaborate

Issue

When New Collaborate is validating an existing user on the Sharing Settings window, the following error appears:

  • We were unable to create the guest user in Microsoft 365. Please refer to the article for troubleshooting steps.

Cause

The guest user was unable to be created, and New Collaborate was unable to resolve the issue. 

Solution

To resolve the issue, you will need to:

  1. Run the New Collaborate Status Check and click "Fix" for any identified errors. Refer to Checking your New Collaborate Status

  2. Verify Entra ID B2B has been configured correctly for New Collaborate. Refer to Setting up Microsoft 365 for New Collaborate

  3. From the Client - Collaborate tab, click the Sharing Settings button. New Collaborate will automatically run the Client Status Check to validate the permissions for the users displayed. Refer to Checking your New Collaborate Status

After completing all three steps above if the error continues to occur, we recommend attempting to manually create the user in Microsoft Entra:

  1. Open Microsoft Entra Admin Centre - https://entra.microsoft.com/ and log in as the Microsoft 365 Administrator.

  2. From the menu on the left-hand side, in the Users section, select All Users.

  3. Select Add User and click Invite External User.

  4. Add the email address and deselect 'Send invite message'
    If Microsoft Entra returns an error or the account does not show in the User list after creating manually, contact your IT professional for further assistance. 

If the user is successfully added to Microsoft Entra perform the Status Check again to verify that the issue has been rectified. Refer to Checking your New Collaborate Status.

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