Features

Why did my automation only run for some jobs or clients, and not all of them?

Issue

I have created an automation that is designed to either:

  • run for a list of jobs in a view
  • run for a list of clients in a view; or
  • run for a selection of clients using a Client - Select filter

However, when I test or run the automation, the following occurs:

  • The automation has only run for some of list and not all of them.
  • I am presented with a message:
    • "No client match all the specified filters"
    • "No job match all the specified filters"

Cause

This issue can be caused by either:

  • When selecting a View in the Automation Process, the option Run Only Once Per Client or Run Only Once per Job is likely enabled. If there are multiple jobs for a single client, the process will only run for one job.

  • When creating an Automation Process with a Client - Select Filter using a custom field, ensure that the associated custom fields contain data. 

Solution

To resolve the issue, you will need to do one of the following:

  • You will need to untick the option Run Only Once Per Client or Run Only Once per Job.  Refer to the section "Filter Type set as View Filter" of the article Setting up Custom Processes.

    Important note: Disabling the "Run once per" toggle will allow the automation to run multiple times for each client or job. It is important that you review your automation to ensure this change does not cause any unintended consequences for your intended outcome.

  • If the process has been created using a Client - Select Filter using a custom field, you will need to add the custom field values for the client. 
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