Error FYI-2120 "Unable to add guest user, this email appears to be associated with an existing user."

Plan: Not Available: Intermediate Available: Pro or Elite

Users: Not Available: All users Available: FYI Admins or User Group permissions

Practice Management Source: Available: All sources

Issue

When trying to share documents with a client or contact using New Collaborate, the following error is displayed:

  • This email appears to be associated with the user (email address). Enter a new email address or update the associated email addresses for this user.

Cause

When adding a client to SharePoint, Microsoft identifies guest user emails associated with existing internal and guest user accounts. New guest user accounts cannot be created where the email address has already been associated with an existing guest user as an Other Address or a Proxy Address.

For some email domains, Microsoft uses the MX records of the primary domain, and redirects the email. For example, the MX record for icloud.com captures emails sent to icloud.com.au, and redirects it to icloud.com. Using hotmail.com.au returns the same error message, whereas Gmail allows both .com and .com.au domains.

The error occurs when either:

  • The guest user is linked to an existing account.
  • The email has been redirected, meaning you will encounter the error message even where there is no Other Address or Proxy Address present.

Solution

Step 1 - Client to remove the Alias from the Account

You'll need to ask the client to check and remove the Alias from their account if present. Otherwise, the client will need to use a different email address for New Collaborate. The following actions in this step depend on whether the client is using a personal Microsoft account (eg Hotmail, Live, Outlook)  or a Work Microsoft account (eg Office 365 account).

Expand the headings below relevant to the type of email account.

Personal Email Account

Provide your client with the following information to remove the Alias, if they are using a personal Microsoft account (eg Hotmail, Live, Outlook):

  1. Log in to https://account.live.com/ with the Microsoft account they're trying to use to log into the Collaborate site. 
     
  2. From the menu on the left, click Your Info.
     
  3. Scroll down, and in the Account info section, click Edit account info in the top right.
     
  4. Click Remove next to the Alias.
Work Email Account

If your client is using a Work Microsoft account (eg Office 365 account), aliases are usually managed centrally in the Microsoft 365 Admin Centre.

Your client will need to contact their IT Administrator to make these changes. Refer to this Microsoft article for more information.

Step 2 - Remove the Alias User from Sharing Settings

You will need to delete the guest user from the client's Sharing Settings in FYI. Click the red button to remove the user.

Refer to Removing Access to the New Collaborate Client Folders

2689_Remove_Individual_User_from_Sharing_Settings.gif

Step 3 - Confirm the user has been removed from SharePoint

  1. Log in to the New Collaborate SharePoint site as the practice's OneDrive Admin User.
     
  2. Click the Settings cog icon in the top right-hand corner. Note that sometimes this may take a few seconds to be displayed. 
     
  3. Click Site Permissions - Advanced Permissions Settings.
     
  4. Click on the SharePoint site Visitors group.
     
  5. Check the list to confirm the client is not displayed.
     
  6. To load the SharePoint Site Collection, in the browser URL, change the MembershipGroupId= value to 0. 
    3654_New_Collaborate_Visitors_Group_URL.gif
  7. The list People and Groups > All People will be displayed.
     
  8. Check the list to confirm the client is not displayed.

Step 4 - Add the user to FYI Sharing Settings

You can now add the client to the FYI Sharing Settings. Refer to Sharing the New Collaborate Client and Upload Folders.

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