Issue
When signing into the FYI add-in (Outlook and Office), the below message displays:
Cause
The application has not been granted permission by a Microsoft 365 Administrator in Microsoft Entra, which prevents the user from proceeding. As admin consent settings are not enabled in Microsoft Entra, the user cannot send a consent request to an administrator for them to approve.
If the message "Approval required" is displayed, refer to When adding a user, and they see a message that it needs to be approved, how do I approve this?
Solution
If the application is being tested by a single user prior to deployment, a Microsoft 365 admin account should be used to grant the application permission when the window pops up.
If the application is to be granted consent across Microsoft 365 and for all users, a Microsoft 365 admin should perform the following after referring to the Microsoft article Grant tenant-wide admin consent in Enterprise apps.
- Sign into entra.microsoft.com.
- Navigate to Identity - Applications - Enterprise applications - All applications.
- Search for the application.
- Select the Permissions option under Security
- Select Grant admin consent
If you receive the same consent window using the admin account in Entra, the account likely does not have the required permissions. You will need to request your IT administrator update the account to have global admin rights, or grand admin consent using the IT's global admin account.